Sending Email Error

Incident Report for Crazy Domains

Resolved

This incident has been resolved.
Posted Oct 03, 2023 - 15:21 AEDT

Investigating

We are currently experiencing issues for some users when sending emails via Web Mail or 3rd-party application. Our engineers are aware of the situation and are investigating the issue.

We apologize for any inconvenience this may cause. We will provide updates as we receive them and when there is a significant change in the situation.
Posted Oct 03, 2023 - 14:47 AEDT
This incident affected: Email Hosting.