Service Interruption | Exchange

Incident Report for Crazy Domains

Resolved

The issue has been resolved. We have increased on one of the mailbox database disks. Outlook Web Access should now be accessible.

Thank you for your patience and understanding.
Posted Sep 22, 2023 - 11:04 AEST

Investigating

We are currently experiencing issues with our Exchange service (Outlook Web Access), affecting some users' ability to access their emails online - https://mail.premium.exchange/. Our engineers are aware of the situation and are investigating the issue.

We appreciate your patience and understanding as we work to resolve this issue. Please check back here for further updates.
Posted Sep 22, 2023 - 09:47 AEST
This incident affected: Email Hosting.