Payment Processing Issue
Incident Report for Crazy Domains
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 09:19 AEST
Identified
We identified that it was an issue generating an invoice after making payments. Payments were processed but some invoices are not being marked as paid.

It is now being looked into and working on a fix. We will post an update once this is completed.

Should you want to get any clarifications, please contact our Support Team.
Posted Apr 19, 2024 - 16:35 AEST
Investigating
We have received concerns that customers' payments are getting stuck to Pending status. This is currently happening when using PayPal when paying invoices on our website or in the member's area.

Please know that our team is investigating the issue and working on resolving it as soon as possible. We apologize for any inconvenience.
Posted Apr 19, 2024 - 11:56 AEST
This incident affected: Account Manager Portal.