Service Interruption | Shared Servers
Incident Report for Crazy Domains
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 18:14 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2024 - 13:12 AEST
Investigating
Some servers are currently experiencing technical issues, affecting users in accessing their emails and websites.

Our engineers are aware of the situation and are investigating the issue.

We appreciate your patience and understanding as we work to resolve this issue. Please check back here for further updates.
Posted Jul 10, 2024 - 10:38 AEST
This incident affected: Web Hosting, Hosting Manager Portal, and Email Hosting.