Service Interruption | Exchange Server
Incident Report for Crazy Domains
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 15:16 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2024 - 12:42 AEST
Investigating
Some Exchange servers are currently experiencing technical issues, affecting users in accessing their emails via Webmail and email client.

Our engineers are aware of the situation and are investigating the issue.

We appreciate your patience and understanding as we work to resolve this issue. Please check back here for further updates.
Posted Jul 23, 2024 - 10:23 AEST
This incident affected: Exchange Email.